Children = Kids?

コンポジットなオブジェクトの構造を辿るときに必ずと言っていいほど見られるメソッド,getChildren()。これを変数で受けるとき,あなたなら変数名をどう命名するだろうか?

Hoge hoge = …; Collection children = hoge.getChildren();

まぁこれが多数派だろう。僕も今までこうしてた。しかし,JavaServer FacesのSun RIは違った。

Hoge hoge = …; Collection kids = hoge.getChildren();

なんてセンスのいい名前だろう。チルドレンではなく,キッズ。インスタンス達を小馬鹿にしている印象もあるが,子供は大好きだ。 今後はkidsでいこうと思う。

このエントリーをはてなブックマークに追加

関連記事

40%キーボードに慣れるためにやったこと

Lunakey PicoでQMK Firmwareを動かしてみました

Googleアシスタント向け会話型アクションが1年後にシャットダウンされます

Google I/O 2022でのGoogleアシスタント関連のセッション

Remap Organizations feature has been released